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1. Introduction 
ViewWave is a simple viewer for strong motion data. ViewWave can read several file formats of 
strong motion data and will show waveforms. ViewWave can perform basic analyses such as a 
Fourier analysis and a response spectrum. You may control sizes and appearances of the graphs as 
you like. The graphs are sent to the Windows clipboard as EMF (Enhanced Metafile) data, so you 
can paste it in your document while keeping its quality. 

The following description is based on the environment of Windows 10. There will be differences 
in terms and file paths according to the environment under other operation systems. 

1.1. System requirements 

ViewWave requires Microsoft .NET Framework 4.5. System requirements will accord with those 
of .NET Framework 4.5. Considering some margins, ViewWave may run in the following 
conditions; 

(1) Operating Systems 

 Windows 7 SP1 (x86 and x64) 
 Windows 8 (x86 and x64) 
 Windows 8.1 (x86 and x64) 
 Windows 10 (x86 and x64) 

Windows Vista SP2 (x86 and x64) and Windows Server families (2008 and 2012) are also supported 
by .NET Framework 4.5, but behavior of ViewWave on those operating systems has not been 
verified. 

(2) Hardware 

 1 GHz and faster CPU 
 2 GB and more RAM 
 1 GB and larger Hard Disk (x86) 
 2 GB and larger Hard Disk (x64) 

(3) Language 

ViewWave has two language modes, i.e. English and Japanese. Japanese messages will appear only 
under the Japanese versions of Windows. 

1.2. Installation and uninstallation 

1.2.1. Installation 

Installation package will be provided as a Windows Installer file (vw2xx.msi). The portion “2xx” 
in the filename represents a version of a release. By double-clicking the installer file, ViewWave is 
installed in “%ProgramFiles%\Strong Motion Tools\ViewWave” (the root folder becomes 
“%ProgramFiles(x86)%” in 64-bit Windows). Shortcuts to ViewWave are added on the desktop and 
program menu “Strong Motion Tools.” 

Uninstallation of ViewWave 1.xx is not necessary to install ViewWave 2.xx. Both can coexist because 
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the installation folder and program group were different. 

1.2.2. Uninstallation 

ViewWave can be uninstalled from [Control Panel] -> [Programs and Features]. 

1.3. Copyright and support 

The copyright of ViewWave is held by T. Kashima, BRI. The author is not responsible for any losses 
caused by ViewWave. 

The up-to-date information and support on ViewWave will be provided on the website 
http://smo.kenken.go.jp/. Any comments and requests are welcomed to kashima@kenken.go.jp. 

1.4. Development tools 

ViewWave is being developed using the following tools; 

 Microsoft Visual Studio Community 2015 Version 14.0.24720.00 Update 1 
 Microsoft .NET Framework Version 4.6.01038 
 GNU Fortran (i686-posix-dwarf-rev0, Built by MinGW-W64 project) 5.2.0 Copyright (C) 2015 

Free Software Foundation, Inc. 

1.5. Changes and new features from ViewWave 1.xx 

ViewWave 2.xx basically follows the features of the previous version. In addition, some new 
features are added and some functions are improved. 

 The development environment was changed from Visual Basic 6.0 to Visual C# and Visual 
Studio 2013. So the entire code was rewritten. 

 English and Japanese versions were integrated into the same package. The language is selected 
according to the current language setting of Windows. 

 Information on strong motion stations and events can be obtained from database files that are 
Microsoft Access and Excel files. 

 Extra data can be plotted on spectrum graphs in addition. For instance, you can compare spectra 
of recoded strong motion data to design spectra. 

 The settings are saved in files rather than the Windows registry. This version does not use the 
Windows registry. 

 Plural reports defined by users can be held. New report types, i.e. channel and combination 
reports, are implemented. 

1.6. Readable data files 

ViewWave can read following strong motion data files; 

 BRI strong motion data files (*.ac) 
 NIED K-NET and KiK-net files (*.ew;*.ew1) 
 JMA 95 Hexa-ASCII files (YMDDhhmm.*) and JMA CSV files (*.csv) 
 Mitutoyo (and Akashi) SMAC-MD/MDU files (*.md) 
 Tokyo Sokushin binary files (*.t3w;*.dbl) 
 Kinemetrics Altus K2/Etna event files (*.evt) 

http://smo.kenken.go.jp/
mailto:kashima@kenken.go.jp


3 
 

 USGS (NSMP) files (*.smc) 
 CGS (CSMIP) files (*.raw; *.v2) 
 COSMOS files (*.v1c; *.v2c) 
 PEER files (*.at2) 
 New Zealand GeoNet files (*.v1a; *.v2a) 
 General CSV and text files (*.csv; *.txt) 

For more information, please refer to Section 4.1 and Section 4.2. 
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2. Basic Usage 
A sample dataset that is used in this chapter can be obtained at the following website. Please 
download vw_sample.zip and extract files to some place if necessary. 

 http://smo.kenken.go.jp/~kashima/viewwave/ 

2.1. Starting/terminating ViewWave 

You can start ViewWave by double-clicking its shortcut on the desktop or in the program menu 
folder “Strong Motion Tools.” After starting up, you can open a strong motion data file from the 
menu [File] -> [Open...]. ViewWave reads a strong motion data file and initially displays 
acceleration waveforms in the main window. When you read 199301152006KSR.ac in the sample 
dataset, the following waveforms will appear. 

 
Fig. 1 ViewWave shows acceleration waveforms after reading a strong motion data file 

ViewWave opens a data file dragged and dropped on the background window as a new file. A 
file dropped on the graph is opened as an appending file. 

You can terminate ViewWave by selecting [Exit] in the [File] menu. [Close] in the [File] menu 
discards the current strong motion data and clears the graph window. 

http://smo.kenken.go.jp/%7Ekashima/viewwave/
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Fig. 2 ViewWave is terminated by the menu [File] -> [Exit] 

2.2. Displaying velocity and displacement waveforms 

ViewWave can display velocity and displacement waveforms that are calculated from the 
acceleration data by the integration. By choosing [Velocity] or [Displacement] in the [View] menu, 
velocity or displacement waveforms will appear in the main window. 

 
Fig. 3 Velocity or displacement waveforms are selectable in the [View] menu 
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(a) A sample of velocity waveforms 

 
(b) A sample of displacement waveforms 

Fig. 4 A sample of velocity and displacement waveforms 

ViewWave provides some methods of integration. The integration method can be selected from 
the [Calculation] tab in the [Option] dialog box that can be opened from the menu [Tool] -> 
[Option]. 

2.3. Displaying Fourier spectra 

To display Fourier spectra of the strong motion data, select the menu [View] -> [Fourier analysis] 
-> [Fourier Spectrum [amplitude]]. The Fourier spectra of all channels will appear in the window. 
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Fig. 5 A sample of Fourier spectrum graph 

The time scope of the Fourier analysis can be changed on the [Calculation] tab in the [Option] 
dialog box. The spectra are smoothed using the Parzen window. The width of Parzen window 
can be changed on the [Calculation] as well. 

2.4. Displaying response spectra 

ViewWave has a function to compute and display response spectra. You can choose a type of 
response spectra from the [Response spectrum] submenu in the [View] menu. There are; 

 Acceleration response spectrum (Sa) 
 Velocity response spectrum (Sv) 
 Displacement response spectrum (Sd) 
 Pseudo velocity response spectrum (on tripartite-axis, pSv) 
 Energy spectrum (Ve) 
 Sa-Sd curve 

Response spectra is usually plotted as the multi-channel single-damping spectra. The channels 
specified on the [Channel] tab in the [Option] dialog are plotted in a response spectrum. 

Damping ratios of the response spectra can be set from the [Calculation] tab in the [Option] dialog. 
There are two damping ratios for the response spectra (Sa, Sv, Sd and pSv), and for the energy 
spectrum (Ve). 

Samples of available response spectra are shown in Fig. 6. 
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(a) Acceleration response spectrum (Sa) 

 
(b) Velocity response spectrum (Sa) 

 
(c) Displacement response spectrum (Sd) 

 
(d) Pseudo velocity response spectrum (pSv) 

 
(e) Energy spectrum (Ve) 

 
(f) Sa-Sd curve 

Fig. 6 Samples of graphs of response spectra 
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ViewWave can plot multi-damping response spectra by selecting “Multi-damping spectra” on the 
[Calculation] tab in the [Option] dialog. For the multi-damping response spectra, you need to 
choose a single channel to be plotted from the [Channel] tab in the [Option] dialog. The damping 
ratios of the multi-damping response spectra can be set from the [Calculation] tab in the [Option] 
as well. Values must be separated by commas. Samples of multi-damping response spectra are 
shown in Fig. 7. 

 
(a) Multi-damping pSv 

 
(b) Multi-damping Ve 

Fig. 7 Samples of multi-damping response spectra 

2.5. Displaying particle orbit 

A particle orbit, which is a projection of sensor movement to a plane, can be selected in the menu 
[View] -> [Particle orbit]. There are three choices, namely, [Acceleration], [Velocity] and 
[Displacement]. 

If the data file has two or more channels, ViewWave initially assigns the first and second channels 
to the vertical and horizontal axes of the particle orbit. Channels to be assigned can be selected on 
the [Channel] tab in the [Option] dialog box. If the data file has data of a single channel, the particle 
orbit is not available. 
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Fig. 8 A sample of a displacement particle orbit graph 

2.6. Displaying Fourier spectrum ratio 

If there are two or more channels, ViewWave can analyze the relation between two channels of data. 
For example, amplitudes of the Fourier spectrum ratio between two channels can be plotted by 
choosing the menu [View] -> [Relation analysis] -> [Fourier spectrum ratio [amplitude]]. 

If two channels can be considered as input and output, the Fourier spectrum ratio represents the 
transfer function. The phase, real part and imaginary part of the Fourier spectrum ratio can be also 
selected from the [View] -> [Relation analysis] submenu. 

Channels for the relation analysis can be set in the [Channel] tab in the [Option] dialog box. If the 
data file has a single channel data, the relation analysis is not available. 
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Fig. 9 A sample of Fourier spectrum ratios 

2.7. Copying and pasting graphs 

There are two ways to send a graph to Windows clipboard. The [Copy] submenu in the [Edit] menu 
sends the current graph to the clipboard as a Windows enhanced metafile (EMF) data. The [Copy 
as image] submenu in the [Edit] menu sends the current graph to the clipboard as a bitmap image. 
Shortcut keys [Ctrl] + [C] and [Ctrl] + [Shift] + [C] are allocated to [Copy] and [Copy as image] 
functions, respectively. 

The graph sent to the clipboard can be pasted into your document as usual. 

 
(a) Copied and pasted as EMF 

 
(b) Copied and pasted as image 

Fig. 10 Graphs copied as EMF can retain its quality even enlarged 
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3. Usage 

3.1. Menu 

This section explains the functions of ViewWave according to the menu structure. ViewWave has 
five main menus as follows; 

 
Fig. 11 Main menu of ViewWave 

3.1.1. File menu 

The [File] menu has the following submenus. 

 
Fig. 12 File menu 

(1) Open… 

The [Open…] menu opens a new data file. This shows an open file dialog box. ViewWave discards 
current data if existing, and reads a specified data file. 
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Fig. 13 Open file dialog box to read a strong motion data file 

File filters on the open file dialog box make it easy to select a target file. 

 
Fig. 14 File filters to read a strong motion data file 

For strong motion data files supported by ViewWave, please refer to Section 4.1. 

(2) Append… 

This appends a data file to the current dataset. This shows the open file dialog box as well. The 
data channels in the specified file are added after the current channels. This will be useful to merge 
data files provided separately, e.g. USGS SMNP “SMC” files and PEER “AT2” files. 

(3) Recent files 

The files that were recently used are listed as the sub-submenus. ViewWave can hold up to 10 files 
as the recently used files. 

(4) Save as AC file… 

This menu saves the current dataset to a file following the “AC” file format. This shows a file save 
dialog box to specify the output file. 
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(5) Export… 

This menu saves the current dataset as an ASCII text file. Further information will be given in 
Section 3.7. 

(6) Close 

This menu discards the current data and clears the graph. 

(7) Print… 

This menu prints the current graph. A print dialog box will appear to select a printer and set options. 

 
Fig. 15 [Print…] submenu calls a print dialog box to print the current graph 

(8) Exit 

This submenu terminates ViewWave. 

3.1.2. Edit menu 

The [Edit] menu contains three submenus; 

 
Fig. 16 Edit menu 

(1) Copy 

This submenu sends the current graph to the clipboard as a Windows enhanced metafile (EMF). 
ViewWave creates the EMF data as full vector graphics, so its quality is retained even enlarged. 
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(2) Copy as image 

This submenu sends the current graph to the clipboard as a bitmap image. For the difference 
between [Copy] and [Copy as image], please refer to Section 2.7. 

(3) Add new channel… 

This creates a new channel of data by an arithmetic operation of two existing channels. You need 
to specify two channels and multiplying factors to add a new channel. 

 
Fig. 17 [Add a new channel] dialog box requires parameters 

The arithmetic operation is as follows; 

𝑥𝑥𝑛𝑛𝑛𝑛𝑛𝑛(𝑡𝑡) = 𝑎𝑎1𝑥𝑥1(𝑡𝑡) + 𝑎𝑎2𝑥𝑥2(𝑡𝑡) (1) 

where 𝑥𝑥𝑛𝑛𝑛𝑛𝑛𝑛(𝑡𝑡) is acceleration data of a new channel, 𝑥𝑥1(𝑡𝑡) and 𝑥𝑥2(𝑡𝑡) are acceleration data of the 
existing channels, 𝑎𝑎1 and 𝑎𝑎2 are multiplier factors. 

The channels #1 and #2 can be selected from the drop-down list boxes and the multiplier factors 
can be set in the text boxes on the right side. A label to identify the new channel is also required to 
be set. 

3.1.3. View menu 

The [View] menu has submenus to select graphs and to change some visual settings on graphs. 
Most of submenus are titled graph types. By selecting a submenu, the specified graph is plotted as 
the current graph. 
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Fig. 18 View menu 

(1) Acceleration 

This submenu shows acceleration waveforms. 

(2) Velocity 

This submenu shows velocity waveforms. The integration method to calculate the velocity can be 
selected from the [Calculation] tab in the [Option] dialog box that can be opened from the menu 
[Tool] -> [Option]. 

(3) Displacement 

This submenu shows displacement waveforms. The integration method to calculate the 
displacement can be selected from the [Calculation] tab in the [Option] dialog box. 

(4) Husid plot 

This submenu shows Husid plots. A Husid plot is the time history of the normalized Arias intensity. 
For more information, please refer to Section 5.5. 

(5) Fourier analysis 

This submenu contains the following sub-submenus. Those are results of the Fourier analysis (See 
Section 5.6). 

 Fourier spectrum [amplitude] 
 Power spectrum 
 Auto correlation coefficient 
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(6) Response spectrum 

This submenu contains the following sub-submenus to select a type of response spectra. 

 Acceleration response spectrum [Sa] 
 Velocity response spectrum [Sv] 
 Displacement response spectrum [Sd] 
 Tripartite pseudo Sv [pSv] 
 Energy spectrum [Ve] 
 Sa-Sd curve 

The response spectrum is a plot of the maximum response of a single-degree-of-freedom system 
having a certain damping ratio as a function of its natural period. Three types of movement, i.e. 
acceleration, velocity and displacement, are treated as the response. So ViewWave can display the 
acceleration [Sa], velocity [Sv] and displacement [Sd] response spectra. 

Another response spectrum, which is called the pseudo response spectrum [pSv], is usually 
utilized in the tripartite plot of the response spectrum. The tripartite plot has horizontal and vertical 
axes scaled in logarithm and diagonal axes representing acceleration and displacement scales. If 
you specify a linear axis for the horizontal or vertical axis, the diagonal axes are not drawn. The 
pseudo response spectrum in ViewWave is calculated from the acceleration response spectrum. 
Further information will be given in Section 5.7. 

The energy spectrum [Ve] is a plot of the total energy input to a single-degree-of-freedom system 
having a certain damping ratio as a function of its natural period. More information is given in 
Section 5.8. 

The Sa-Sd curve is a plot representing the relation between the maximum acceleration response 
[Sa] and maximum displacement response [Sd] of various periods. It is sometimes called the 
Acceleration-Displacement Response Spectra (ADRS) format. 

(7) Particle orbit 

A type of the particle orbit can be selected from the following three sub-submenus. 

 Acceleration 
 Velocity 
 Displacement 

An acceleration sensor normally has three channels of data in the three directions orthogonal to 
each other. So the movement of a sensor is in three dimensions and can be projected to a plane. 
ViewWave calls such projection a particle orbit. This is also referred to as a Lissajous plot (or curve). 
As a particle orbit, ViewWave takes two channels being orthogonal and plots on an X-Y graph. 
Acceleration, velocity and displacement can be selected as the plotting data. A pair of channels for 
a particle orbit can be set in the [Channel] tab on the [Option] dialog box. 

(8) Relation 

This submenu contains the following sub-submenus. Those are results of the relation analysis (See 
Section 5.9). 

 Fourier spectral ratio [amplitude] 
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 Fourier spectral ratio [phase] 
 Cross spectrum 
 Cross-correlation coefficient 
 Coherence 
 Response spectral ratio 
 Fourier spectral ratio [real] 
 Fourier spectral ratio [imaginary] 

Plural pairs of channels can be plotted in a graph and the combination of channels can be specified 
in the [Channel] tab on the [Option] dialog box. 

(9) Report 

A report that is a combination of various graphs can be selected. Please refer to Subsection 3.4.6 
and Section 3.6 for further information. 

(10) Time axis 

Selecting one of the following sub-submenus, time axis of waveforms can be controlled. 

 Backward: shifts waveforms backward. 
 Forward: shifts waveforms forward. 
 Magnify: magnifies time of waveforms. 
 Reduce: reduces time of waveforms. 

(11) Zoom 

Selecting one of the following sub-submenus, the graph is zoomed in or out. 

 50%: zooms out to 50% of original. 
 75%: zooms out to 75% of original. 
 100%: returns to original. 
 125%: zooms in to 125% of original. 
 150%: zooms in to 150% of original. 
 200%: zooms in to 200% of original. 

(12) Legend 

Selecting one of the following sub-submenus, the legend position is changed. 

 None: hides the legend. 
 Upper left: places the legend on the upper left corner. 
 Upper right: places the legend on the upper right corner. 
 Lower left: places the legend on the lower left corner. 
 Lower right: places the legend on the lower right corner. 
 Change cyclically: changes the legend place cyclically. 

(13) Grid 

Selecting one of the following sub-submenus, the grid style is changed. 

 None: hides the grid. 
 Major: plots grid lines at the positions of major ticks. 
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 Full: plots grid lines at the positions of all ticks. 
 Change cyclically: changes the grid style cyclically. 

(14) Mark/Unmark peaks 

This submenu switches visibility of marks on peaks of waveforms and spectra. The shape of marks 
can be specified on the [Appearance] tab in the [Option] dialog box. 

3.1.4. Tool menu 

The [Tool] menu has several submenus related to settings and information. Submenus that control 
visibilities of the tool bar, status bar and menu bar are also placed here. 

 
Fig. 19 Tool menu 

(1) Peak values… 

This submenu shows a window containing the peak values of data on the current graph. 

 
Fig. 20 A sample of a window showing peak values 

(2) Station and event… 

This submenu shows the [Station and event] dialog box. In the dialog box, you can see information 
on the strong motion station and the seismic event. The information is obtained from the data file 
and can be inquired to databases. Use of databases is explained in Chapter 3.9. 
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Fig. 21 A sample of station and event dialog box 

(3) Properties… 

This submenu shows a window to show the information on the strong motion data. 

 
Fig. 22 A sample of a window showing properties 

(4) Option… 

This submenu shows the [Option] dialog box. Please refer to Chapter 3.4. 

(5) Preprocessing… 

This submenu shows the [Preprocessing] dialog box. Please refer to Chapter 3.5. 

(6) Database 

This submenu has two sub submenus to specify database settings for stations and events. 

ViewWave can use databases to get information on strong motion stations and seismic events. The 
databases for the strong motion stations and the seismic events are specified individually. 
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Fig. 23 Databases for station and events can be selected 

The station database requires the following parameters; 

  Use station database: enables to set the following parameters if checked. 
 Source: is a database filename. 
 Table: is a table name. 
 Fields: requires following fields to be specified. 
 Code: is a field of station codes. This will be a unique identifier. 
 Name: is a field of station names. 
 Latitude: is a field of station latitudes. 
 Longitude: is a field of station longitude. 

 
Fig. 24 Database tab in the Option dialog box 

The event database requires the following parameters; 

  Use event database: enables to set the following parameters if checked. 
 Source: is a database filename. 
 Table: is a table name. 
 Fields: require following fields to be specified. 
 Origin time: is a field of origin time. 
 Epicenter: is field of epicenter names or event names. 
 Latitude: is a field of event latitudes. 
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 Longitude: is a field of event longitudes. 
 Depth: is a field of event depths. 
 Magnitude: is a field of event magnitudes. 

 
Fig. 25 Database tab in the Option dialog box 

(7) Hide/Show tool bar 

This submenu switches visibility of the tool bar. 

(8) Hide/Show status bar 

This submenu switches visibility of the status bar. 

(9) Hide/Show menu bar 

This submenu switches visibility of the main menu. 

3.1.5. Help menu 

The Help menu has the following submenus; 

(1) Visit website 

This submenu opens the ViewWave website using the default browser. 

(2) About… 

This submenu shows you a typical about box as follows. 
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Fig. 26 About box 

3.2. Tool bar 

Buttons on the tool bar can be used as shortcuts to the function assigned to the submenus. 

 
Fig. 27 ViewWave tool bar 

Each button has a function which is allocated the following menu; 

 [File] -> [Open…] 

 [File] -> [Append…] 

 [File] -> [Print…] 

 [Edit] -> [Copy] 

 [View] -> [Acceleration] 

 [View] -> [Velocity] 

 [View] -> [Displacement] 

 [View] -> [Fourier analysis] Inverted triangle ( ) shows submenus. 

 [View] -> [Response spectrum] Inverted triangle ( ) shows submenus. 

 [View] -> [Particle orbit] Inverted triangle ( ) shows submenus. 

 [View] -> [Relation] Inverted triangle ( ) shows submenus. 

 [View] -> [Report] Inverted triangle ( ) shows submenus. 

 [View] -> [Zoom] Inverted triangle ( ) shows submenus. 

 [View] -> [Time axis] -> [Backward] 

 [View] -> [Time axis] -> [Forward] 

 [View] -> [Time axis] -> [Magnify] 
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 [View] -> [Time axis] -> [Reduce] 

 [Tool] -> [Peak values…] 

 [Tool] -> [Properties…] 

 [Tool] -> [Options…] 

3.3. Shortcut key 

ViewWave assigns the following shortcut keys; 

[Ctrl] + [C] Copy a current graph and send it to the clipboard as EMF 
[Ctrl] + [Shift] + [C] Copy a current graph and send it to the clipboard as image 
[Ctrl] + [G] Change grid style 
[Ctrl] + [K] Switch visibility of peak marks 
[Ctrl] + [L] Change legend position 
[Ctrl] + [M] Hide/show menu bar 
[Ctrl] + [O] Open a new data file 
[Ctrl] + [P] Print a current graph 
[Ctrl] + [S] Save current data to a file as AC file 
[Ctrl] + [W] Close current data 
[Alt] + [F4] Terminate ViewWave 
[F2] Show acceleration waveforms 
[F3] Show velocity waveforms 
[F4] Show displacement waveforms 
[F5] Show Husid plot 
[F6] Show Fourier spectrum [amplitude] 
[F7] Show power spectrum 
[F8] Show auto-correlation coefficient 
[Shift] + [F2] Show acceleration response spectrum 
[Shift] + [F3] Show velocity response spectrum 
[Shift] + [F4] Show displacement response spectrum 
[Shift] + [F5] Show pseudo velocity response spectrum as tripartite plot 
[Shift] + [F6] Show energy spectrum 
[Ctrl] + [F2] Show acceleration particle orbit 
[Ctrl] + [F3] Show velocity particle orbit 
[Ctrl] + [F4] Show displacement particle orbit 

3.4. Settings 

Various settings can be controlled from the [Option] dialog box that is opened by choosing the 
menu [View] -> [Option...]. The [Option] dialog has nine tabs as follows. 

 Axis 
 Appearance 
 Channel 
 Size 
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 Calculation 
 Report 
 Extra 
 Misc. 

There are four buttons on the lower side of the [Option] dialog box to deal with the settings. 

 
Fig. 28 Buttons on the Option dialog box 

 [File…]: Load or save settings from/to a file, set current setting as default, or delete default 
settings. 

 [Apply]: Apply changes and refresh the graph 
 [OK]: Close the dialog and apply changes. 
 [Cancel]: Cancel all changes and close the dialog. 

The settings, which can be changed in the [Option] dialog box, can be saved as the default settings 
or to a setting file. By clicking [File…] button, the menu will appear as follows; 

 
Fig. 29 File menu in the Option dialog box 

 [Load settings from a file…]: loads settings from a file which was saved previously. 
 [Save settings to a file…]: saves current settings to a file. 
 [Set current settings as default]: saves current settings as the default settings. This saves 

settings to the special file that is loaded when ViewWave starts. 
 [Delete default settings]: deletes the default setting file. 

3.4.1. Axis tab 

A scale and a label of an individual axis can be edited on the [Axis] tab. Available axes are listed in 
the list box on the left side. By selecting an axis, axis parameters appear on the right side. 
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Fig. 30 Axis tab in the Option dialog box 

There are eight axis parameters. 

  Specify axis scales: uses parameters specified if checked. If not checked, the parameters 
suitably adjusted by ViewWave. In cases of [Time], [Frequency], [Period] and [TimeLag] axes, 
the parameters must be specified by users. 

  Scale in logarithm: uses a logarithm axis if checked. It disappears when the logarithm axis 
is not available, such as the [Time] axis, the [Acceleration] axis, etc. 

 Minimum: specifies the minimum value of the axis. In some cases, it disappears because only 
the maximum value is necessary. In case of waveforms, the minimum value is always a negative 
of the maximum value. In case of linear vertical axis of a spectrum, the minimum value is always 
zero. 

 Maximum: specifies the maximum value of the axis. 
 Major tick interval: sets the interval of major ticks. Ticks and annotating values are drawn. 

Zero to leave it to ViewWave. If the logarithm axis is selected, it cannot be specified. 
 Minor tick interval: sets the interval of minor ticks. Only ticks are drawn. Zero to leave it to 

ViewWave. If the logarithm axis is selected, it cannot be specified. 
 Label: sets the label of the axis. 
 Unit: displays the unit of the current axis. This is not editable. 

In addition, [Axis] tab has the following settings. 
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 Display unit of acc.: selects a display unit of acceleration from “cm/s²”, “cm/s/s”, “m/s²”, 
“m/s/s”, “gal”, “g” and “G”. 

 Vel. and disp.: selects display units of velocity and displacement “cm/s, cm” and “m/s, m”. 
 Legend position: select a legend position from “None”, “Lower-left”, “Upper-left”, , “Lower-

right” and “Upper-right”. 
 Grid style: select a grid style from “None”, “Major only” and “Full”. 
 Periods to be plotted on Sa-Sd curve: Specifies periods to be plotted on a Sa-Sd curve. 
  Draw auto-correlation on one side: plots auto-correlation coefficients on the single side if 

checked. The auto-correlation coefficients are also calculated in the negative range, but it must 
be symmetric. 

3.4.2. Appearance tab 

Appearance of most elements of graphs can be controlled in the [Appearance] tab. The elements 
appear in the list box on the left side. 

 
Fig. 31 Appearance tab in the Option dialog box 

After selecting an element in the list box on the left hand side, you can see and change line attributes, 
namely, width, color and style. The elements are; 

 Frame: affects an outer frame of a graph. The font affects a graph title. 
 Axis: affects X and Y axes of a graph. The font affects axis annotations and labels. 
 Grid: affects grid lines of a graph. The font affects annotations on diagonal axes. 
 Legend: affects an area to plot a legend. The font affects legend labels. 
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 PeakMark: affects marks plotted on peak positions. 
 Wave1 ~ Wave12: affects lines to draw waveforms. 
 Spec1 ~ Spec12: affects lines to draw spectra. 
 Extra1 ~ Extra12: affects lines to draw extra data. 

In the case of Frame and Legend, a fill color and an alpha value can be specified by checking [ 
Fill background]. The alpha value indicates the transparency effect in the range between 0 and 255, 
where 0 is fully transparent color and 255 is fully opaque color. In the case of Frame, Axis, Grid 
and Legend, font parameters can be edited as well. Those fonts affect the graph elements described 
in the list above. For PeakMark, the line attributes, fill color, size and shape of marks can be 
specified. 

3.4.3. Channel tab 

On the [Channel] tab, you can select channels to be plotted. Pairs of channels to draw particle orbits 
and to perform relation analysis can be set as well. 

 
Fig. 32 Channel tab in the Option dialog box 

The channels checked in the list box on the left side are plotted as waveforms, Fourier spectra and 
response spectra. By clicking on a label twice (or pressing [F2] key) like renaming in the Windows 
Explorer, you can edit the channel label. 
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Fig. 33 Twice-clicking allows you to edit channel label 

The channel to be used to plot multi-damping response spectra can be selected from the drop-
down box at the lower left. 

The pair of channels for the particle orbit can be selected in the upper-left group box. Two channels 
for the horizontal and vertical axes need to be selected from the dropdown boxes. In addition, the 
mode of plotting particle orbits can be chosen from the followings. 

 All time of record: plots all time of the record. 
 Specified time: plots the time range specified by [Start time] and [Time length]. 
 Sync with waveforms: plots the time range same with waveforms. 
 Multiple graph: plots multiple graphs spliced by the specified time intervals. 

Moreover, the [Specified time] and [Multiple graph] graphs require some parameters; 

 Number of columns: sets the number of columns for plotting the [Multiple graph] graphs. 
 Time interval [s]: sets the time intervals for slicing of the [Multiple graph] graphs. 
 Start time [s]: sets the start time of [Specified time] and [Multiple graph] graphs to be plotted. 
 Time length [s]: sets the time length of [Specified time] and [Multiple graph] graphs to be 

plotted. 

 
Fig. 34 A sample of multiple graphs of particle orbit 
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In the [Relation] group box, the channel pairs of the relation analysis can be set. Clicking [Edit] 
button after selecting a pair (or double clicking on it), a dialog box appears as follows. You may 
select a pair of channels for X (input) and Y (output) from this dialog box. The [Add] button adds 
a new channel pair and the [Remove] button removes selected channel pear. 

 
Fig. 35 Channel setting dialog box for relation analysis 

3.4.4. Size tab 

Sizes of graphs and graph elements can be set on the [Size] tab. 

 
Fig. 36 Size tab in the Option dialog box 

 Waveform: sets the width and height of waveforms. 
 Spectrum: sets the width and height of graphs excepting waveforms and particle orbits. 
 Particle orbit: sets the length of the sides of the normal and multiple orbit graphs (those are 

square). 
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 Margins: sets the left, right, top and bottom margins of the page. 
 Graph space: sets the vertical spacing between two waveforms. 
 Heights of ticks: sets the heights of major and minor ticks. 
 Legend: sets the length of sample lines and space around the legend. 

3.4.5. Calculation tab 

On the [Calculation] tab, parameters for the integration, Fourier analysis and response spectrum 
are editable. 

 
Fig. 37 Calculation tab in the Option dialog box 

(1) Integration 

As the integration method, there are choices as follows; 

 FFT (in frequency domain): integrates in the frequency domain using the Fast Fourier 
Transform (FFT). 

 Seismograph simulation: integrates by simulating traditional seismographs. 
 Trapezoidal rule: integrates based on the trapezoidal rule with the linear baseline correction of 

velocity. 

[Low-cut frequency] needs to be set if [FFT] is selected. The natural frequencies and damping 
ratios of the velocity sensor and the displacement sensor must be specified if [Seismograph 
simulation] is selected. Please refer to Section 5.4 for more details. 



32 
 

(2) Fourier analysis 

In the Fourier analysis, analyzing time can be selected as [Time scope] from the followings; 

 All time of record: analyzes all time of the record. 
 Specified time: analyzes the time range specified by [Start time] and [Time length]. 
 Sync with waveforms: analyzes the time range same with waveforms. 

Specifying the [Width of Parzen window] is necessary in all cases. In addition, the start time and 
time length for analysis are required if [Specified time] is selected. 

Further information is given in Section 5.6. 

(3) Response spectrum 

For response spectrum, the following parameters are needed. 

  Divide period geometrically: divides period geometrically if checked. Otherwise it is 
divided arithmetically. 

 Number of periods: sets the number of periods to be calculated. 
 Period range: sets the calculation period range by the [Lower] and [Upper] periods. 
  Plot multi-damping spectra: plots response spectra of a single channel with multi-damping 

instead of single-damping multi-channel spectra. 
 Damping ratio: sets the damping ratios for Sa, Sv, Sd and pSv in the [Resp.] textbox, and for Ve 

in the [Energy] textbox. If the “multi-damping spectra” is selected, set damping ratios separated 
by commas. 

 
Fig. 38 Damping ratios for multi-damping spectra 

Further information is given in Section 5.7. 

3.4.6. Report tab 

A report is a combination of various graphs. ViewWave can have several reports defined by users. 
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Fig. 39 Report tab in the Option dialog box 

There are three types of report; 

 Combination report: contains some of present graphs. It can contain relation graphs and 
particle orbit graphs in addition to waveforms and spectra. 

 Channel report: contains waveforms and spectra of a single channel. 
 Sensor report: contains waveforms and spectra of a single sensor. A sensor consists of three 

channels of records sequentially stored. 

To add a report, click [Add…] button on the upper right corner. A context menu asks you to choose 
a report type. 

 
Fig. 40 Context menu to ask report type on the Report tab 

An added report primarily has an acceleration waveform. You may change the graph type, the 
position and the size of the graph. The upper left corner is the origin of the coordinate system. The 
position of the graph is specified by the coordinates of the upper-left point of the graph. The unit 
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of the position and size of graphs is millimeter. In addition, you may control visibilities of the title, 
legend, X-axis label and Y-axis label of each graph by checking the checkboxes. You can add 
another graph by clicking [Add] button in the [Containing graphs] group box. 

In addition to the graphs of strong motion data, [Text box] can be selected as a graph. You can add 
some message to the report and use the placeholders (see Section 3.10) in the message. 

 
Fig. 41 Selectable graphs on the Report tab 

For more information, please refer to Section 3.6. 

3.4.7. Extra tab 

In addition to graphs of the current strong motion data, you can add plots of extra data. For 
instance, if you have data of design spectra or response spectra of other strong motion data, you 
can compare with your data by overlaying those on your graph. The [Extra] tab manages the extra 
data to be plotted additionally. 
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Fig. 42 Extra tab in the Option dialog box 

Clicking the [Read…] button opens a file open dialog box to select an extra data file. After reading 
extra data files, data are listed in the tree view. To edit a data label, click on the label twice like 
renaming on the Windows Explorer. You can control the plotting by checking or unchecking those 
check boxes. [Delete] button deletes extra data currently focused. 

For further information, please refer to Chapter. 3.8. 

3.4.8. Misc. tab 

Miscellaneous settings are arranged on the [Misc.] tab. 
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Fig. 43 Misc. tab in the Option dialog box 

There are following items; 

  Draw Fourier spectra with period: takes periods as the horizontal axis for spectra that are 
functions of frequencies, e.g. Fourier spectrum and Fourier spectrum ratio. 

  Draw graph title: draws a title of a graph if checked. The title is drawn above the graph.  
You can edit the title of each graph. 

  Fix plotting interval of waves: fixes an interval of plotting steps for waveforms to the given 
value if checked. It will be adjusted according to the spacing of plotting intervals if unchecked. 

  Clip drawing lines exceeded graph size: clips drawing lines of waves and spectra if checked. 
  Use EMF+ for sending a graph to clipboard: uses EMF+ when copy a graph and send to the 

clipboard, if checked. This is a reminder of development process, and will be needless. Anyway 
it is kept for the future. 

  Overlay waves in one graph: plots all waveforms on one graph if checked. Usually those are 
plotted on separated graphs. If it is checked, you may specify the shifting rate of waves. When 
zero is set as the shifting rate, waves completely overlaid. The shifting rate 0.5 vertically shifts 
the next wave a half of the p-p value.  
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(a) [Overlay waves in one graph] is unchecked 

 

(b) [Overlay waves in one graph] is checked (Shifting rate is 0) 

 
(b) [Overlay waves in one graph] is checked (Shifting rate is 0.5) 

Fig. 44 Appearance of waves 

 

  Mark peaks: puts marks on the peak positions of waveforms and spectra. 
  Force Sa-Sd curve to be linear: forces linear axes for both Sa and Sd even it logarithm axes 

are specified. 
  Save settings as default when closing ViewWave: saves current settings as default if 

checked. Those are usually discarded when ViewWave terminates. 
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3.5. Preprocessing 

Preprocessing means processes applying before displaying waveforms. The preprocessing 
parameters can be confirmed and changed in the [Preprocessing setting] dialog box that can be 
called from the menu [Tool] -> [Preprocessing…]. 

 
Fig. 45 Preprocessing setting dialog box 

There are the following items; 

  Remove offset: removes offsets of strong motion data using average values for the time given 
as [Time to estimate offset], if checked. If zero is given, the averages in the whole time are used 
as the offsets. 

  Use band-pass filter: applies the band pass filter with given low-cut and high-cut frequencies 
to strong motion data if checked. The gain characteristics of the low- and high-cut filter are the 
Butterworth filter (amplitude only), so you may specify the order of the Butterworth filter as 
well. If zero is set to the order, JMA filters, that is used to calculate JMA intensity, are utilized 
instead. For further information, see Section 5.10.1. 

  Rotate wave: rotates the strong motion data in the horizontal plane if checked. Channels 
must be stored in order of Y (North-South), X (East-West) and Z (Up-Down). [Rotational angle] 
gives the rotational angle in degrees. If [Rotational angle] is zero and the data file is a BRI AC 
file, the data is converted to the N000°E and N090°E directions. For further information, see 
Section 5.10.25.10.1. 

  Multiply factor: multiplies strong motion data by given factors. Plural factors separated by 
commas can be given. Those factors are applied sequentially and cyclically. 

  Trim time of wave data: trims the strong motion data by specified [Start time] and [Time 
length] if checked. 
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 Downsampling interval: specifies an interval of the downsampling of the strong motion data. 
If 1 is set, the downsampling is not made. If the original sampling frequency is 100 Hz, it will 
be reduced to 50 Hz if 2 is set as the downsampling interval. 

 Number of continuous files to be read: specifies a number of files to be read in case of data 
files that can have continuous files, such as JMA-95 intensity meter files, Tokyo Sokushin T3W 
files. 

  Select channels to be used after reading a file: shows a dialog box to pick channels to be 
used after reading a data file, if checked. The dialog box is like below. The left list box has a list 
of channels contained in the data file. You can move channels that you want to use by double-
clicking on the label or the [->] button. Only the channels contained in the list box on the right 
side are used in ViewWave. This can be utilized to change the channel order from the original 
one. 

 
Fig. 46 Picking channels dialog box 

  Inquire station and event to database: inquires information on station and event after 
reading a data file if checked. 

  Show this dialog every time: shows this dialog every time after reading a data file if checked. 

3.6. Report 

ViewWave has a function to draw a report containing some graphs as mentioned in Subsection 
3.4.6. There are three types of reports; 

 Combination report: is a report contains some of present graphs. It can contain relation graphs 
and particle orbit graphs in addition to waveforms and spectra. 

 Channel report: is a report contains waveforms and spectra of a single channel. 
 Sensor report: is a report contains waveforms and spectra of a single sensor. A sensor consists 

of three channels of records sequentially stored. 

ViewWave initially has four sample reports which are named; 

 Acc, Vel, Fourier and pSv in A4: is a report similar with the report of ViewWave 1.xx. 
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 Acc and pSv of a sensor in line: is a sensor report containing acceleration waveforms and 
pseudo velocity response spectrum. 

 Waves of a channel: is a channel report containing acceleration, velocity and displacement 
waveforms, and a Husid plot. 

 Transfer Functions (Amp-Phase and Real-Imaginary): is a combination graph containing 
amplitude, phase, real part and imaginary part of the Fourier spectral ratio. 

As a sample of the channel reports, the report [Waves of a channel] is shown in Fig. 47. If a channel 
report is selected, a dropdown textbox appears on the right side on the main menu in order to 
select a channel quickly. 

 
Fig. 47 A sample of channel reports (199301152006KSR.ac) 

As a sample of the sensor reports, the report [Acc and pSv of a sensor in line] is shown in Fig. 48. 
If a sensor report is selected, a dropdown textbox appears on the right side on the main menu for 
quick selection of a sensor. 
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Fig. 48 A sample of sensor reports (199301152006KSR.ac) 

As a sample of the combination reports, the report named [Transfer Functions (Amp-Phase and 
Real-Imaginary)] is shown in Fig. 49. 

 
Fig. 49 A sample of combination reports (199410042222KSR.ac) 
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3.7. Export of data 

All data that ViewWave has can be output to a file. To export some data, select the menu [File] -> 
[Export…]. ViewWave shows a dialog box to select the exporting data and file form. 

Available data are listed in the drop down box which is labeled [Exporting data]. 

 
Fig. 50 Export data dialog box – available data 

As a file form, there are three choices; 

 CSV (comma-separated-value) file: is a file having the row-column structure. Each data is 
separated by comma. The file extension becomes “.csv.” 

 TSV (tab-separated-value) file: is a file having the row-column structure. Each data is 
separated by tab. The file extension becomes “.tsv.” 

 Text (blocked text) file: is a file having the channel-blocked structure. Each data has a fixed 
width. The file extension becomes “.txt.” 

When the [OK] button is clicked, a dialog box to specify an output file will appear. 

 
Fig. 51 Export data dialog box – file forms 

Fig. 52 to Fig. 54 show samples of exported data files. 
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Sa - 199301152006KSR.ac 
3,201 
Period(s),063-GL,153-GL,UP-GL 
0.0500,7.79555e+02,8.24798e+02,6.87348e+02 
0.0515,7.98907e+02,8.88687e+02,7.50852e+02 
0.0531,7.94407e+02,8.84150e+02,7.63344e+02 
0.0547,8.25074e+02,8.65764e+02,6.96613e+02 
0.0564,7.98642e+02,9.10080e+02,7.60011e+02 
0.0581,8.21047e+02,9.08989e+02,8.31120e+02 
0.0598,8.30904e+02,9.71435e+02,7.43404e+02 
0.0617,8.63603e+02,1.01370e+03,6.94255e+02 
0.0635,8.90775e+02,1.07676e+03,6.55854e+02 
0.0655,9.70367e+02,1.12468e+03,7.08700e+02 
0.0675,9.71469e+02,1.06264e+03,7.16422e+02 
0.0695,1.07218e+03,1.04733e+03,7.43857e+02 
0.0716,1.06161e+03,1.01046e+03,8.18442e+02 
0.0738,1.15156e+03,1.11292e+03,7.87680e+02 
0.0761,1.27118e+03,1.14262e+03,8.36992e+02 
0.0784,1.35789e+03,1.11770e+03,7.51543e+02 
0.0807,1.35590e+03,1.22319e+03,7.18125e+02 
0.0832,1.22240e+03,1.33923e+03,8.81456e+02 
0.0857,1.18985e+03,1.35933e+03,8.51492e+02 
0.0883,1.18774e+03,1.42165e+03,7.84052e+02 
0.0910,1.25453e+03,1.50457e+03,7.93264e+02 
0.0938,1.25083e+03,1.62780e+03,8.13613e+02 
0.0966,1.21623e+03,1.51436e+03,8.22576e+02 
0.0996,1.21793e+03,1.37149e+03,8.78917e+02 
0.1026,1.19039e+03,1.28254e+03,9.76938e+02 
0.1057,1.28020e+03,1.27934e+03,1.01636e+03 
 (snipped...) 

Fig. 52 A sample of exported CSV data files 

Sa - 199301152006KSR.ac 
3 201 
Period(s) 063-GL 153-GL UP-GL 
0.0500 7.79555e+02 8.24798e+02 6.87348e+02 
0.0515 7.98907e+02 8.88687e+02 7.50852e+02 
0.0531 7.94407e+02 8.84150e+02 7.63344e+02 
0.0547 8.25074e+02 8.65764e+02 6.96613e+02 
0.0564 7.98642e+02 9.10080e+02 7.60011e+02 
0.0581 8.21047e+02 9.08989e+02 8.31120e+02 
0.0598 8.30904e+02 9.71435e+02 7.43404e+02 
0.0617 8.63603e+02 1.01370e+03 6.94255e+02 
0.0635 8.90775e+02 1.07676e+03 6.55854e+02 
0.0655 9.70367e+02 1.12468e+03 7.08700e+02 
0.0675 9.71469e+02 1.06264e+03 7.16422e+02 
0.0695 1.07218e+03 1.04733e+03 7.43857e+02 
0.0716 1.06161e+03 1.01046e+03 8.18442e+02 
0.0738 1.15156e+03 1.11292e+03 7.87680e+02 
0.0761 1.27118e+03 1.14262e+03 8.36992e+02 
0.0784 1.35789e+03 1.11770e+03 7.51543e+02 
0.0807 1.35590e+03 1.22319e+03 7.18125e+02 
0.0832 1.22240e+03 1.33923e+03 8.81456e+02 
0.0857 1.18985e+03 1.35933e+03 8.51492e+02 
0.0883 1.18774e+03 1.42165e+03 7.84052e+02 
0.0910 1.25453e+03 1.50457e+03 7.93264e+02 
0.0938 1.25083e+03 1.62780e+03 8.13613e+02 
0.0966 1.21623e+03 1.51436e+03 8.22576e+02 
0.0996 1.21793e+03 1.37149e+03 8.78917e+02 
0.1026 1.19039e+03 1.28254e+03 9.76938e+02 
0.1057 1.28020e+03 1.27934e+03 1.01636e+03 
 (snipped...) 

Fig. 53 A sample of exported TSV data files. Values are separated by tabs. 



44 
 

Sa - 199301152006KSR.ac 
            3          201 
Period(s) 
       0.0500       0.0515       0.0531       0.0547       0.0564       0.0581 
       0.0598       0.0617       0.0635       0.0655       0.0675       0.0695 
       0.0716       0.0738       0.0761       0.0784       0.0807       0.0832 
       0.0857       0.0883       0.0910       0.0938       0.0966       0.0996 
       0.1026       0.1057       0.1090       0.1123       0.1157       0.1192 
       0.1228       0.1266       0.1304       0.1344       0.1385       0.1427 
       0.1470       0.1515       0.1561       0.1608       0.1657       0.1708 
(snipped...) 
       6.4068       6.6016       6.8024       7.0092       7.2224       7.4420 
       7.6683       7.9015       8.1418       8.3894       8.6445       8.9074 
       9.1783       9.4574       9.7450      10.0414      10.3467      10.6614 
      10.9856      11.3197      11.6639      12.0186      12.3841      12.7607 
      13.1488      13.5487      13.9607      14.3852      14.8227      15.2735 
      15.7379      16.2165      16.7097      17.2178      17.7414      18.2810 
      18.8369      19.4097      20.0000 
063-GL 
  7.79555e+02  7.98907e+02  7.94407e+02  8.25074e+02  7.98642e+02  8.21047e+02 
  8.30904e+02  8.63603e+02  8.90775e+02  9.70367e+02  9.71469e+02  1.07218e+03 
  1.06161e+03  1.15156e+03  1.27118e+03  1.35789e+03  1.35590e+03  1.22240e+03 
  1.18985e+03  1.18774e+03  1.25453e+03  1.25083e+03  1.21623e+03  1.21793e+03 
(snipped...) 

Fig. 54 A sample of exported text data files 

3.8. Extra data 

In addition to graphs of the current strong motion data, you can add plots of extra data. For 
instance, if you have data of design spectra or response spectra of other strong motion data, you 
can compare with your data by overlaying those on your graph. The extra data to be added can be 
specified in the [Extra] tab of [Option] dialog box. 

The extra data will be read from a file and a format of the extra data file must be a comma-
separated-value file (*.csv) or a tab-separated-value file (*.tsv). An example of extra files is shown 
below (kokuji_psv.csv in the sample data). 

2,154 
Period(s),Mare,Gokumare 
0.1026,2.050306552,10.25153276 
0.1057,2.143545565,10.71772783 
0.109,2.24481681,11.22408405 
0.1123,2.348167892,11.74083946 
0.1157,2.456826155,12.28413078 
0.1192,2.570986404,12.85493202 
0.1228,2.690849175,13.45424587 
0.1266,2.820056251,14.10028125 
0.1304,2.952021163,14.76010582 
0.1344,3.093910978,15.46955489 
0.1385,3.24251936,16.2125968 
0.1427,3.398081221,16.9904061 
0.147,3.560837204,17.80418602 
0.1515,3.734944754,18.67472377 
0.1561,3.916918696,19.58459348 
0.1608,4.094738376,20.47369188 
0.1657,4.219515851,21.09757926 
0.1708,4.349386285,21.74693142 
0.176,4.481803197,22.40901599 
0.1813,4.616766589,23.08383295 
(snipped) 

Fig. 55 A sample of extra data files (kokuji_psv.csv) 
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The first line must have a keyword indicating a data type as the first word. The keyword of each 
data type is described in the list below. The second line has a number of data columns and a number 
of data steps. The third line has labels of data. The data part starts from the fourth line. 

The first value must be frequencies or periods. The second and following values are data. Number 
of data lines must be the same as the number of data steps in the second line. Please note that the 
number of data columns in the second line does not include frequencies or periods. This format is 
the same as the export files of ViewWave. 

 
Fig. 56 A sample of displaying extra data on pSv 

ViewWave supports following data type as an extra data; 

 FspAmp: is overlaid with the Fourier spectrum [amplitude]. 
 Power: is overlaid with the power spectrum. 
 Sa: is overlaid with the acceleration response spectrum. 
 Sv: is overlaid with the velocity response spectrum. 
 Sd: is overlaid with the displacement response spectrum. 
 pSv: is overlaid with the pseudo velocity response spectrum. 
 Ve: is overlaid with the energy spectrum. 
 SaSd: is overlaid with the Sa-Sd curve. 
 FspRatioAmp: is overlaid with the Fourier spectrum ratio [amplitude]. 
 FspRatioPhase: is overlaid with the Fourier spectrum ratio [phase]. 
 FspRatioReal: is overlaid with the Fourier spectrum ratio [real]. 
 FspRatioImag: is overlaid with the Fourier spectrum ratio [imaginary]. 
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 Cross: is overlaid with the cross spectrum. 
 Coherence: is overlaid with the coherence function. 
 RespRatio: is overlaid with the response spectrum ratio. 

3.9. Information on station and event 

Information on the strong motion station and seismic event, which can be obtained from the data 
file, can be confirmed on the [Station and event] dialog box. The [Database…] button calls the 
[Database] tab in the [Option] dialog box to change the settings. 

 
Fig. 57 Station and event dialog box 

If the database files are already specified, additional information can be get from the databases by 
clicking the [Inquire to database by code] or [Inquire to database by time] button. 

To inquire station information to the database, the station code in the [Code] textbox is used as a 
search key. ViewWave searches a station having the same station code from the database. 

To inquire event information to the database, origin time, which is time starting an event, in the 
[Origin time] textbox is used as a search key. If the database doesn’t have the origin time of the 
event, ViewWave sets record time in the textbox. You may set a feasible time by yourself. ViewWave 
searches events having the near origin time to the given time from the database. 
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Fig. 58 Station and event dialog box after inquiring to databases 

If [ Inquire station and event to database] in the [Preprocessing] dialog box is checked, the 
database inquiry is performed just after reading a data file. 

3.10. Placeholder 

The graph titles and report texts can contain some placeholders that is replaced with actual 
information when the title or text is displayed. Available placeholders are as follows; 

 %c: is replaced with the number of channels of the acceleration data. 
 %C: is replaced with the station code. 
 %d: is replaced with the sampling time interval of the acceleration data. 
 %D: is replaced with the depth of the event with a unit [km]. 
 %e: is replaced with the damping ratio of energy spectrum in percent. 
 %E: is replaced with the event description in a form “[Origin Time] at [Epicenter] (h=[Depth]km, 

M[Magnitude])”. 
 %f: is replaced with the sampling frequency with a unit [Hz]. 
 %F: is replaced with the full filename of the strong motion data. 
 %h: is replaced with the damping ratio of response spectra in percent. 
 %i: is replaced with the JMA seismic intensity. If a sensor report is selected as the current graph, 

the intensity of the target sensor of the report is used. If a channel report is selected, the intensity 
of the sensor having the target channel of the report is used. Otherwise, the intensity of the first 
sensor is used. 

 %M: is replaced with the magnitude of the event. 
 %n: is replaced with the number of steps of the acceleration data. 
 %N: is replaced with the short filename of the strong motion data. 
 %o: is replaced with the time range of particle orbit. 
 %O: is replaced with the origin time of the event. 
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 %Q: is replaced with the epicenter of the event. 
 %r: is replaced with the start time of record. 
 %R: is replaced with the new line. So the following text goes to the next line. 
 %S: is replaced with the station name. 
 %t: is replaced with the time range used in Fourier analysis with a unit [s]. 
 %w: is replaced with the width of Parzen window with a unit [Hz]. 

 
(a) Message specified in the report setting 

 
(b) Message appeared on the report 

Fig. 59 Use of placeholders 
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4. Technical Information 

4.1. Supported data file 

ViewWave can read various strong motion data files. ViewWave can treat strong motion data 
having the unit of cm/s2. So the unit of data is converted to cm/s2 when those are read. 

4.1.1. BRI strong motion data files 

Building Research Institute, Japan is providing strong motion data obtained that strong motion 
network. The data file has a file extension (ac) and consists multi-channel data recorded at a station. 
Please refer to; 

 BRI Strong motion observation: http://smo.kenken.go.jp/ 
 Strong motion data file (.ac file): BRI Strong motion observation: http://smo.kenken.go.jp/ 

smn/acfile 

4.1.2. NIED K-NET and KiK-net files 

The National Research Institute for Earth Science and Disaster Prevention (NIED) is operating two 
large strong motion networks in Japan. The networks, which are called K-NET and KiK-net, 
provide strong motion data at the website. 

A station of K-NET has a strong motion instrument on the ground and the instrument has a three-
component acceleration sensor. A strong motion record consists of three files with file extensions, 
“EW”, “NS” and “UD.” 

A KiK-net station has two acceleration sensors on the ground and in the borehole. The borehole 
sensor is usually placed on the seismic bedrock. Each sensor measures three-component 
accelerations. A strong motion record consists of six files with file extensions, “EW1,” “NS1,” ”UD1,” 
“EW2,” “NS2” AND “UD2.” 

In case of both K-NET and KiK-net, ViewWave tries to read all files if one of data files is specified. 
Please refer to; 

 NIED strong-motion seismograph networks: http://www.kyoshin.bosai.go.jp/ 
 About K-NET ASCII format: http://www.kyoshin.bosai.go.jp/kyoshin/man/knetform_en.html 

4.1.3. JMA data files 

The Japan Meteorological Agency (JMA) deploys seismic intensity meters throughout Japan. The 
seismic intensity meter is an equipment to measure the JMA seismic intensity scale and works as a 
strong motion instrument as well. The strong motion records of the JMA seismic intensity meters 
are annually published from the Japan Meteorological Business Support Center (JMBSC). The 
publication, usually by CD or DVD, may include some strong motion data obtained in the seismic 
information networks of the local governments. There are two types of data files, i.e. a Hexa-ASCII 
converted file and a CSV file. A Hexa-ASCII file doesn’t have a fixed file extension, because that 
portion is occupied by the station code. ViewWave can read those data files. 

 JMA 95 Hexa-ASCII files (YMDDhhmm.*) 
 JMA CSV files (*.csv) 

http://smo.kenken.go.jp/
http://smo.kenken.go.jp/%20smn/acfile
http://smo.kenken.go.jp/%20smn/acfile
http://www.kyoshin.bosai.go.jp/
http://www.kyoshin.bosai.go.jp/kyoshin/man/knetform_en.html


50 
 

There are several types of seismic intensity meters and there are differences of sensitivity among 
those. Unfortunately, there is no way to know the intensity meter type from the data file. So 
ViewWave adjusts the amplitudes based on comparison of the peak values of the data and on the 
file header. 

For more information, please refer to; 

 Japan Meteorological Agency (JMA): http://www.jma.go.jp/ 
 Japan Meteorological Business Support Center (JMBSC): http://www.jmbsc.or.jp/ 

4.1.4. Binary files 

Some strong motion instruments or dedicated software make binary files having peculiar formats. 
ViewWave can read some of such files directly. Currently, ViewWave supports the following binary 
files; 

 Mitutoyo (and Akashi) SMAC-MD/MDU files (*.md) 
 Tokyo Sokushin win32 binary files (*.t3w) 
 Tokyo Sokushin binary files (*.dbl) 
 Kinemetrics Altus K2/Etna event files (*.evt) 

Mitutoyo, which merged Akashi, SMAC-MD/MDU instruments make a data file having a file 
extension “SMC” and some utility software puts “DAT” as a file extension. I usually replace the 
file extensions with “md” to avoid confusion. ViewWave checks file contents if those file extensions 
are found, therefore you don’t need to rename your data files. 

ViewWave may read Kinemetrics “EVT” files, probably only made by K2 and Etna. Unfortunately, 
I never have an opportunity to try other instruments. 

4.1.5. Major database files in United States 

The United States of America leads the world in the field of strong motion instrumentation. There 
are several databases accessible on the Internet. ViewWave supports three major file formats as 
follows. 

 USGS (NSMP) files (*.smc) 
 CGS (CSMIP) files (*.raw; *.v2) 
 COSMOS files (*.v1c; *.v2c) 

Further information on those data files is available at the following website; 

 NSMP Data - USGS: http://earthquake.usgs.gov/monitoring/nsmp/data.php 
 SMC-format Data Files: http://escweb.wr.usgs.gov/nsmp-data/smcfmt.html 
 Center for Engineering Strong Motion Data: http://strongmotioncenter.org/ 
 Data Format in “About CESMD”: http://strongmotioncenter.org/aboutcesmd.html 

4.1.6. PEER database files 

Another often referred database in the United States will be the PEER Ground Motion Database at 
the University of California, Berkeley. ViewWave can read those acceleration files which have the 
file extension “AT2.” 

http://www.jma.go.jp/
http://www.jmbsc.or.jp/
http://earthquake.usgs.gov/monitoring/nsmp/data.php
http://escweb.wr.usgs.gov/nsmp-data/smcfmt.html
http://strongmotioncenter.org/
http://strongmotioncenter.org/aboutcesmd.html
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 PEER Ground Motion Database: http://ngawest2.berkeley.edu/ 

4.1.7. New Zealand GeoNet files 

GeoNet in New Zealand is operating the strong motion network covering the country. ViewWave 
can read those files having file extensions “V1A” and “V2A.” 

 Strong-Motion Data - GeoNet: http://info.geonet.org.nz/display/appdata/Strong-Motion+Data 

4.2. General CSV and text files 

There is a possibility that ViewWave can read ASCII-coded text files having different format. 
ViewWave assumes that there are two styles of data structure. One is a row-column style, and 
another is a channel-block style. 

In the row-column style, a line has all channel data sampled at the same time, and data at the next 
step are in the following line. The row-column style may have some header lines. As the first data, 
after the header lines, channel labels can be placed. Comma-separated-values (CSV) files are 
usually in this style. 

In the channel-block style, all data of each channel are written in a block, and blocks are stored in 
a file sequentially. The channel-block style files can have some header lines and each channel block 
can have some channel header lines. BRI AC files and major US strong motion files are in this style. 

ViewWave shows a dialog box to ask the way to read the data file, if an unknown file is specified. 
To read a CSV file, the following parameters are required. 

 
Fig. 60 Setting parameter dialog box for reading a row-column (CSV) data file 

http://ngawest2.berkeley.edu/
http://info.geonet.org.nz/display/appdata/Strong-Motion+Data
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 Data structure style: specifies data style described above. This is fixed to “Row-column style” 
in case of CSV files. 

 Number of channels: is a number of channels containing in the data file, excluding ignored 
first column. 

 Number of data steps: is a number of steps of data, excluding a channel label line. 
 Sampling frequency: is a sampling frequency of data. 
 Conversion factor to cm/s/s: is a value to be multiplied by data. 
 Number of header lines: is a number of header lines to be skipped. If the file has a row of 

channel labels, exclude it. 
  Ignore first column: ignores the first data in each line if checked. When each line has time as 

the first value, it must be checked. 
  First row contains channel labels: let ViewWave get channel labels from the first line if 

checked. 

To read a text file, [Data structure style] can be selected from “Row-column style” and “Channel-
block style.” If “Channel-block style” is selected, some other parameters are required. 

 
Fig. 61 Setting parameter dialog box for reading a channel-block data file 

 Number of channel header lines: is a number of channel headers in each channel block to be 
skipped. 

  Specify details: enables to set the following options in addition; 
 First column position: specifies start position of data in each line. 
 Column width: is a width of each column. 
 Number of columns in a line: is a number of data written in a line. 
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5. Analysis Method 
This chapter briefly explains how ViewWave analyzes strong motion data. And furthermore, the 
principles are not described herein; therefore, please refer to the references or technical books if 
necessary. 

The variable names used in this chapter are not sufficiently unified. For instance, time histories of 
acceleration, velocity and displacement are normally represented by 𝑎𝑎(𝑡𝑡) , 𝑣𝑣(𝑡𝑡)  and 𝑑𝑑(𝑡𝑡) , 
respectively. However, 𝑥̈𝑥(𝑡𝑡), 𝑥̇𝑥(𝑡𝑡) and 𝑥𝑥(𝑡𝑡) are used for acceleration, velocity and displacement 
when talking about seismic response. Also 𝑇𝑇  sometimes represents the natural period and 
sometimes the duration time. 

5.1. Fourier transform 

ViewWave frequently uses the Fourier transform and inverse Fourier transform in the analysis. A 
function 𝑎𝑎(𝑡𝑡) of time 𝑡𝑡 can be transformed to a function 𝐴𝐴(𝑓𝑓) of frequency 𝑓𝑓 by Eq. (2)1), 2). 
𝐴𝐴(𝑓𝑓) can transformed by 𝑎𝑎(𝑡𝑡) using Eq. (3). Eqs. (2) and (3) are known as the Fourier transform 
and inverse Fourier transform, respectively. 

𝐴𝐴(𝑓𝑓) = � 𝑎𝑎(𝑡𝑡)𝑒𝑒−𝑖𝑖2𝜋𝜋𝜋𝜋𝜋𝜋𝑑𝑑𝑑𝑑
∞

−∞
 (2) 

𝑎𝑎(𝑡𝑡) = � 𝐴𝐴(𝑓𝑓)𝑒𝑒𝑖𝑖2𝜋𝜋𝜋𝜋𝜋𝜋𝑑𝑑𝑑𝑑
∞

−∞
 (3) 

In case of discretely sampled data having a finite duration, the Fourier transforms are given by the 
following equations; 

𝐴𝐴𝑘𝑘 =
1
𝑁𝑁
� 𝑎𝑎𝑗𝑗𝑒𝑒

−𝑖𝑖�2𝜋𝜋𝑁𝑁 �𝑘𝑘𝑘𝑘 ,  (𝑘𝑘 = 0, 1, … ,𝑁𝑁 − 1)
𝑁𝑁−1

𝑗𝑗=0

 (4) 

𝑎𝑎𝑗𝑗 = �𝐴𝐴𝑘𝑘𝑒𝑒
𝑖𝑖�2𝜋𝜋𝑁𝑁 �𝑘𝑘𝑘𝑘 ,  (𝑗𝑗 = 0, 1, … ,𝑁𝑁 − 1)

𝑁𝑁−1

𝑘𝑘=0

 (5) 

Based on Eq. (4), the Fourier transform in ViewWave is performed in the following procedure; 

1) Set the number of data 𝑁𝑁 that is greater than or equal to the original number of data 𝑁𝑁0 and is a 
power of 2. 

2) Add zeros to 𝑎𝑎𝑁𝑁O  to 𝑎𝑎𝑁𝑁−1, if necessary. 
3) Perform the Fast Fourier Transform (FFT)3). 

5.2. Seismic response of SDOF system 

In some analyses, seismic response of a single-degree-of-freedom (SDOF) system is calculated. The 
equation of motion a SDOF system as shown in Fig. 62 is given by Eq. (6). The equation of motion 
can be also written as Eq. (7) using a natural circular frequency 𝜔𝜔0 and a damping ratio h. 
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Fig. 62 Single-degree-of-freedom system 

𝑚𝑚𝑥̈𝑥(𝑡𝑡) + 𝑐𝑐𝑥̇𝑥(𝑡𝑡) + 𝑘𝑘𝑘𝑘(𝑡𝑡) = −𝑚𝑚𝑥̈𝑥𝑔𝑔(𝑡𝑡) (6) 

𝑥̈𝑥(𝑡𝑡) + 2ℎ𝜔𝜔0𝑥̇𝑥(𝑡𝑡) + 𝜔𝜔0
2𝑥𝑥(𝑡𝑡) = −𝑥̈𝑥𝑔𝑔(𝑡𝑡) (7) 

where m is mass, k is stiffness, c is a damping coefficient, 𝜔𝜔0 = �𝑘𝑘 𝑚𝑚⁄  is a natural circular 
frequency and ℎ = 𝑐𝑐 (2𝑚𝑚𝜔𝜔0)⁄  is a damping ratio. 𝑥̈𝑥(𝑡𝑡), 𝑥̇𝑥(𝑡𝑡) and 𝑥𝑥(𝑡𝑡) are time series of response 
acceleration, velocity and displacement of the system, respectively. 𝑥̈𝑥𝑔𝑔(𝑡𝑡) is a time series of input 
acceleration. 

The response of the SDOF system to the input motion 𝑥̈𝑥𝑔𝑔(𝑡𝑡) can be calculated by the following 
equations; 

𝑥𝑥(𝑡𝑡) = −
1
𝜔𝜔𝑑𝑑

� 𝑥̈𝑥𝑔𝑔(𝜏𝜏)𝑒𝑒−ℎ𝜔𝜔0(𝑡𝑡−𝜏𝜏) sin𝜔𝜔𝑑𝑑(𝑡𝑡 − 𝜏𝜏)𝑑𝑑𝑑𝑑
𝑡𝑡

0
 (8) 

𝑥̇𝑥(𝑡𝑡) = −� 𝑥̈𝑥𝑔𝑔(𝜏𝜏)𝑒𝑒−ℎ𝜔𝜔0(𝑡𝑡−𝜏𝜏) �cos𝜔𝜔𝑑𝑑(𝑡𝑡 − 𝜏𝜏) −
ℎ

√1 − ℎ2
sin𝜔𝜔𝑑𝑑(𝑡𝑡 − 𝜏𝜏)� 𝑑𝑑𝑑𝑑

𝑡𝑡

0
 (9) 

𝑥̈𝑥(𝑡𝑡) + 𝑥̈𝑥𝑔𝑔(𝑡𝑡)

= 𝜔𝜔𝑑𝑑 � 𝑥̈𝑥𝑔𝑔(𝜏𝜏)𝑒𝑒−ℎ𝜔𝜔0(𝑡𝑡−𝜏𝜏) ��1 −
ℎ2

1 − ℎ2
� sin𝜔𝜔𝑑𝑑(𝑡𝑡 − 𝜏𝜏)

𝑡𝑡

0

−
2ℎ

√1 − ℎ2
cos𝜔𝜔𝑑𝑑(𝑡𝑡 − 𝜏𝜏)� 𝑑𝑑𝑑𝑑 

(10) 

where 𝜔𝜔𝑑𝑑 is the damped natural circular frequency (𝜔𝜔𝑑𝑑 = √1 − ℎ2𝜔𝜔0). 

ViewWave calculates the seismic response of a SDOF system by the Nigam and Jennings method4) 
assuming that the initial velocity 𝑥̇𝑥(0) and displacement 𝑥𝑥(0) are zero. 

5.3. JMA Seismic intensity scale 

The Japan Meteorological Agency (JMA) defined the seismic intensity scale by the following 
equation5); 

𝐼𝐼JMA = 2 log𝑎𝑎0 + 0.94 (11) 

where 𝐼𝐼JMA  is the JMA seismic intensity scale, and 𝑎𝑎0  is the maximum of a that satisfies the 
following equation. 

x(t): relative displacement
        (x(t): acc., x(t): vel.)

m
k/2

c

xg(t): input acceleration..

k/2

.. .

ω0
2 = k/m

2ω0h = c/m
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� 𝑤𝑤(𝑡𝑡,𝑎𝑎)𝑑𝑑𝑑𝑑
𝑇𝑇𝑑𝑑

0
≥ 0.3 (12) 

where 𝑇𝑇𝑑𝑑  is the duration of acceleration record. 𝑤𝑤(𝑡𝑡,𝑎𝑎) = 0 when 𝑣𝑣(𝑡𝑡) < 𝑎𝑎0 , and 𝑤𝑤(𝑡𝑡,𝑎𝑎) = 1 
when 𝑣𝑣(𝑡𝑡) ≥ 𝑎𝑎0. 𝑣𝑣(𝑡𝑡) is a time history of the vectorial amplitude given by the following equation. 

𝑣𝑣(𝑡𝑡) = �𝑎𝑎X′
2(𝑡𝑡) + 𝑎𝑎Y′

2(𝑡𝑡) + 𝑎𝑎Z′
2(𝑡𝑡) (13) 

where 𝑎𝑎X
′ 2

(𝑡𝑡), 𝑎𝑎Y
′ 2

(𝑡𝑡), and 𝑎𝑎Z
′ 2

(𝑡𝑡) are filtered accelerations in the three directions N-S, E-W, and 
U-D on the ground, respectively. The three types of filters shown in Eq. (14) to Eq. (16) are applied 
using the FFT and the inverse FFT conversions. 

𝑊𝑊T(𝑓𝑓) = (1/𝑓𝑓)1 2⁄  (14) 

𝑊𝑊L(𝑓𝑓) = (1 − 𝑒𝑒−(𝑓𝑓/𝑓𝑓L)3)1/2 (15) 

𝑊𝑊H(𝑓𝑓) = (1 + 0.694𝑦𝑦2 + 0.241𝑦𝑦4 + 0.0557𝑦𝑦6 + 0.009664𝑦𝑦8 + 0.00134𝑦𝑦10

+ 0.000155𝑦𝑦12)−
1
2, 𝑦𝑦 =

𝑓𝑓
𝑓𝑓H

 (16) 

𝐴𝐴′𝑗𝑗(𝑓𝑓) = 𝐴𝐴𝑗𝑗(𝑓𝑓)𝑊𝑊T(𝑓𝑓)𝑊𝑊L(𝑓𝑓)𝑊𝑊H(𝑓𝑓), 𝑗𝑗 = X, Y 𝑎𝑎𝑎𝑎𝑎𝑎 Z (17) 

where 𝑊𝑊T(𝑓𝑓), 𝑊𝑊L(𝑓𝑓) and 𝑊𝑊H(𝑓𝑓) are the weight functions of the three types of filters. 

𝑊𝑊T(𝑓𝑓) emphasizes the low frequency components in consideration of human feeling. 𝑊𝑊L(𝑓𝑓) and 
𝑊𝑊H(𝑓𝑓) are the low-cut and the high-cut filters, respectively. 𝑓𝑓L and 𝑓𝑓H are the corner frequencies 
of the low-cut and high-cut filters. For the calculation of the JMA seismic intensity, 𝑓𝑓L = 0.5Hz and 
𝑓𝑓H = 10Hz are used. The shapes of the three filters and the overall frequency characteristics are 
illustrated in Fig. 63. 

 
Fig. 63 Characteristics of filters used to calculate JMA seismic intensity 

Based on the definition of the JMA seismic intensity above, ViewWave applies the following 
procedure for every 40 seconds of the strong motion data and adopts the maximum one as the JMA 
seismic intensity. 
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1) Calculate Fourier transforms 𝐴𝐴X(𝑓𝑓),𝐴𝐴Y(𝑓𝑓),𝐴𝐴Z(𝑓𝑓) from the three time histories of acceleration data 
𝑎𝑎X(𝑡𝑡),𝑎𝑎Y(𝑡𝑡),𝑎𝑎Z(𝑡𝑡) using the fast Fourier transform (FFT). 

2) Apply the filters 𝑊𝑊T(𝑓𝑓), 𝑊𝑊L(𝑓𝑓) and 𝑊𝑊H(𝑓𝑓) to 𝐴𝐴𝑗𝑗(𝑓𝑓) in the frequency domain as shown in Eq. 
(17). 

3) Calculate the filtered time histories 𝑎𝑎′X(𝑡𝑡),𝑎𝑎′Y(𝑡𝑡),𝑎𝑎′Z(𝑡𝑡) from 𝐴𝐴′X(𝑓𝑓),𝐴𝐴′Y(𝑓𝑓),𝐴𝐴′Z(𝑓𝑓) by the inverse 
Fourier transform using FFT. 

4) Calculate the vectorial amplitude 𝑣𝑣(𝑡𝑡) by Eq. (13). 
5) Search 𝑎𝑎0 that satisfies Eq. (12) using the bisection method. 
6) Calculate the JMA seismic intensity by Eq. (11). 

The calculation of the JMA intensity requires three component accelerations of a sensor, so 
ViewWave calculates the JMA intensity using consecutive three channels assuming that those are 
in the three directions of one sensor. If the assumption is not satisfied, the values don’t make sense. 
If the total number of channels is less than three, the calculation of the JMA seismic intensities is 
skipped. 

5.4. Integration 

ViewWave basically deals with acceleration data, so velocity and displacement data are calculated 
from acceleration data by the integration. ViewWave provides some integration methods. 

5.4.1. FFT (in frequency domain) 

The integration in the frequency domain is as follows using Fourier transforms; 

𝑉𝑉(𝑓𝑓) =
𝐴𝐴(𝑓𝑓)
𝑖𝑖2𝜋𝜋𝜋𝜋

 (18) 

𝐷𝐷(𝑓𝑓) = −
𝐴𝐴(𝑓𝑓)

(2𝜋𝜋𝜋𝜋)2
 (19) 

where 𝑉𝑉(𝑓𝑓), 𝐷𝐷(𝑓𝑓) and 𝐴𝐴(𝑓𝑓) are Fourier transforms of the velocity 𝑣𝑣(𝑡𝑡), displacement 𝑑𝑑(𝑡𝑡) and 
acceleration 𝑎𝑎(𝑡𝑡), respectively. i is the imaginary unit (𝑖𝑖 = √−1). 

This method may be also applied together with a low-cut (high-pass) filter to reduce the drift due 
to the magnification of low frequency noises. So the procedure will be as follows; 

1) Calculate the Fourier transform 𝐴𝐴(𝑓𝑓) of the acceleration time history 𝑎𝑎(𝑡𝑡) using FFT. 
2) Integrate 𝐴𝐴(𝑓𝑓) in the frequency domain by Eq.(18) and Eq.(19). 
3) Low-cut filtering (𝑉𝑉′(𝑓𝑓) = 𝑊𝑊L(𝑓𝑓)𝑉𝑉(𝑓𝑓), 𝐷𝐷′(𝑓𝑓) = 𝑊𝑊L(𝑓𝑓)𝐷𝐷(𝑓𝑓), where 𝑊𝑊L(𝑓𝑓) is the low-cut filter). 
4) Calculate the velocity and displacement time histories 𝑣𝑣(𝑡𝑡) and 𝑑𝑑(𝑡𝑡) from 𝑉𝑉′(𝑓𝑓) and 𝐷𝐷′(𝑓𝑓) by 

the inverse Fourier transform using FFT. 

The low-cut filter indicated in Eq. (15) is utilized here and the cut-off frequency 𝑓𝑓L can be specified 
as a parameter. 

5.4.2. Seismograph simulation 

A simple seismograph is an application of a mass-spring-damper system as shown in Fig. 62. Such 
a system is also called a single-degree-of-freedom (SDOF) system. The movement of the mass can 
represent ground acceleration, ground velocity or ground displacement, according to the natural 
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frequency and the damping ratio of the system. In the frequency domain, the ratios of the response 
displacement 𝑋𝑋(𝜔𝜔) to the ground acceleration 𝑋̈𝑋𝑔𝑔(𝜔𝜔), velocity 𝑋̇𝑋𝑔𝑔(𝜔𝜔) and displacement 𝑋𝑋𝑔𝑔(𝜔𝜔) 
can be formulated as Eq.(20) to Eq.(22) using a circular frequency (𝜔𝜔 = 2𝜋𝜋𝜋𝜋). 

𝑋𝑋(𝜔𝜔)
𝑋̈𝑋𝑔𝑔(𝜔𝜔)

= −
1

𝜔𝜔0
2 − 𝜔𝜔2 + 2𝑖𝑖ℎ𝜔𝜔0𝜔𝜔

 (20) 

𝑋𝑋(𝜔𝜔)
𝑋̇𝑋𝑔𝑔(𝜔𝜔)

= −
𝑖𝑖𝑖𝑖

𝜔𝜔0
2 − 𝜔𝜔2 + 2𝑖𝑖ℎ𝜔𝜔0𝜔𝜔

 (21) 

𝑋𝑋(𝜔𝜔)
𝑋𝑋𝑔𝑔(𝜔𝜔) =

𝜔𝜔2

𝜔𝜔0
2 − 𝜔𝜔2 + 2𝑖𝑖ℎ𝜔𝜔0𝜔𝜔

 (22) 

where 𝜔𝜔0  and h are the natural circular frequency (ω0 = 2𝜋𝜋𝑓𝑓0 ) and the damping ratio of the 
system, respectively. The frequency characteristics of Eq.(21) and Eq.(22) for ω0 = 1.0 are shown 
in Fig. 64. Looking at the case of ℎ = 5 in the graph of 𝑋𝑋(𝜔𝜔) 𝑋̇𝑋𝑔𝑔(𝜔𝜔)⁄ , there is the flat part of the 
amplitude in the middle range of the circular frequency. In that frequency range, it can work as a 
velocity meter. So the response displacement 𝑥𝑥(𝑡𝑡) can represent the ground velocity 𝑥̇𝑥𝑔𝑔(𝑡𝑡). The 
graph of 𝑋𝑋(𝜔𝜔) 𝑋𝑋𝑔𝑔(𝜔𝜔)⁄  also suggests that the system with the damping ratio of about 0.7 can work 
as the displacement meter in the high frequency range. 

 
(b) 𝑋𝑋(𝜔𝜔) 𝑋̇𝑋𝑔𝑔(𝜔𝜔)⁄  

 
(a) 𝑋𝑋(𝜔𝜔) 𝑋𝑋𝑔𝑔(𝜔𝜔)⁄  

Fig. 64 Frequency characteristics of the response of a SDOF system (𝜔𝜔0 = 1.0) 

To use the seismograph simulation as the integration method, you need to specify the natural 
frequencies and damping ratios of velocity and displacement meters. ViewWave calculates the 
seismic response of the system using the Nigam and Jennings method following the procedure 
below; 
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1) Compute the response displacement 𝑥𝑥V(𝑡𝑡) of the system with a natural frequency 𝑓𝑓V and a damping 
ratio ℎV. The initial values of 𝑓𝑓V and ℎV are 1.0 Hz and 4.0. 

2) Convert the response displacement 𝑥𝑥V(𝑡𝑡) to the integrated velocity 𝑥̇𝑥g(𝑡𝑡). 𝑥̇𝑥g(𝑡𝑡) = −4𝜋𝜋𝑓𝑓VℎV𝑥𝑥V(𝑡𝑡) 
3) Compute the response displacement 𝑥𝑥D(𝑡𝑡) of the system with a natural frequency 𝑓𝑓D and a damping 

ratio ℎD. The initial values of 𝑓𝑓D and ℎD are 0.1 Hz and 0.7071. 
4) Convert the response displacement 𝑥𝑥D(𝑡𝑡) to the integrated displacement 𝑥𝑥g(𝑡𝑡). 𝑥𝑥g(𝑡𝑡) =  −𝑥𝑥D(𝑡𝑡) 

5.4.3. Trapezoidal rule 

The integration in the time domain can be formulized as follows; 

𝑣𝑣(𝑡𝑡) = � 𝑎𝑎(𝜏𝜏)𝑑𝑑𝑑𝑑
𝑡𝑡

−∞
 (23) 

where 𝑣𝑣(𝑡𝑡) and 𝑎𝑎(𝑡𝑡) are velocity and acceleration time histories, respectively. 

For discrete acceleration sampled at the equal-interval, the velocity at the k-th step (𝑣𝑣𝑘𝑘) can be 
approximated using the trapezoidal rule as follows; 

𝑣𝑣𝑘𝑘 = 𝑣𝑣𝑘𝑘−1 +
(𝑎𝑎𝑘𝑘−1 + 𝑎𝑎𝑘𝑘)

2
Δ𝑡𝑡 (24) 

where 𝑣𝑣𝑘𝑘−1 and 𝑣𝑣𝑘𝑘 are velocities at (𝑘𝑘 − 1)-th and 𝑘𝑘-th steps, 𝑎𝑎𝑘𝑘−1 and 𝑎𝑎𝑘𝑘 are accelerations at 
(𝑘𝑘 − 1)-th and 𝑘𝑘-th steps, Δ𝑡𝑡 is a sampling interval. 

The integrated velocity by Eq. (23) may drift, so a baseline correction and/or a low-cut filter are 
usually used together. In ViewWave, the integration procedure using the trapezoidal rule is as 
follows; 

1) Integrate the acceleration to get velocity by the trapezoidal rule ( 𝑎𝑎(𝑡𝑡) → 𝑣𝑣(𝑡𝑡),  𝑣𝑣(0) = 0). 
2) Correct the baseline of the velocity using the linear regression (𝑣𝑣(𝑡𝑡) → 𝑣𝑣′(𝑡𝑡)). 
3) Integrate the velocity to get displacement by the trapezoidal rule (𝑣𝑣′(𝑡𝑡) → 𝑑𝑑(𝑡𝑡), 𝑑𝑑(0) = 0). 

ViewWave holds 𝑣𝑣′(𝑡𝑡) and 𝑑𝑑(𝑡𝑡) as the results. Actually, the integrated displacement still seems 
to have some unneeded drift. 

5.5. Husid plot 

A Husid plot6) is the time history of the Arias intensity7) normalized by its maximum value. The 
Arias intensity is defined by the following equation. 

𝐼𝐼𝐴𝐴 =
𝜋𝜋

2𝑔𝑔
� 𝑎𝑎2(𝑡𝑡)𝑑𝑑𝑑𝑑
𝑇𝑇𝑑𝑑

0
 (25) 

where 𝐼𝐼𝐴𝐴 is the Arias intensity, 𝑇𝑇𝑑𝑑 is the duration time. 

So the Husid plot is expressed by the following equation. 

𝐻𝐻(𝑡𝑡) =
∫ 𝑎𝑎2(𝜏𝜏)𝑑𝑑𝑑𝑑𝑡𝑡
0

∫ 𝑎𝑎2(𝜏𝜏)𝑑𝑑𝑑𝑑𝑇𝑇𝑑𝑑
0

 (26) 

In ViewWave, the Husid plot is calculated as follows; 
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ℎ𝑘𝑘 =
∑ 𝑎𝑎𝑗𝑗2𝑘𝑘
𝑗𝑗=0

∑ 𝑎𝑎𝑗𝑗2𝑁𝑁−1
𝑗𝑗=0

 (27) 

where ℎ𝑘𝑘 is the Husid plot at the k-th step, 𝑎𝑎𝑗𝑗 is the acceleration at the j-th step and N is the 
number of steps of acceleration data. 

5.6. Fourier analysis 

5.6.1. Fourier and power spectra 

A power spectrum is defined as follows; 

𝑃𝑃(𝑓𝑓) = lim
𝑇𝑇→∞

1
𝑇𝑇
𝐴𝐴(𝑓𝑓)𝐴𝐴∗(𝑓𝑓) (28) 

To estimate the time average of strong motion data, ViewWave applies a spectrum window to a 
power spectrum. The spectrum window has an effect of smoothing the spectrum. 

ViewWave displays the smoothed Fourier spectrum 𝐹𝐹�(𝑓𝑓)  and the power spectrum 𝑃𝑃�(𝑓𝑓) 
obtained from the acceleration data 𝑎𝑎(𝑡𝑡) by the following procedure; 

1) Calculate the Fourier transform 𝐴𝐴(𝑓𝑓) of the acceleration time history 𝑎𝑎(𝑡𝑡) represented by Eq. (2) 
using the Fast Fourier Transform (FFT). 

2) Calculate the raw power spectrum 𝑃𝑃(𝑓𝑓) by Eq. (29), where 𝐴𝐴∗(𝑓𝑓) is the complex conjugation of 
𝐴𝐴(𝑓𝑓), T is the duration time. 

3) Calculate the smoothed power spectrum 𝑃𝑃�(𝑓𝑓) by Eq. (30), where 𝑊𝑊(𝑓𝑓) is the Parzen window 
defined by Eq. (31). 

4) Calculate the smoothed Fourier spectrum 𝐹𝐹�(𝑓𝑓) by Eq. (32). 

 

𝑃𝑃(𝑓𝑓) =
1
𝑇𝑇
𝐴𝐴(𝑓𝑓)𝐴𝐴∗(𝑓𝑓) (29) 

𝑃𝑃�(𝑓𝑓) = � 𝑃𝑃(𝑓𝑓 − 𝜙𝜙)𝑊𝑊(𝜙𝜙)𝑑𝑑𝑑𝑑
∞

−∞
 (30) 

𝑊𝑊(𝑓𝑓) =
3
4
𝑢𝑢 �

sin𝜋𝜋𝜋𝜋𝜋𝜋2
𝜋𝜋𝜋𝜋𝜋𝜋

2

�

4

 (31) 

𝐹𝐹�(𝑓𝑓) = �𝑃𝑃�(𝑓𝑓)𝑇𝑇 (32) 

5.6.2. Autocorrelation coefficient 

The autocorrelation function and the power spectrum have the following relation via the Fourier 
transform. So ViewWave calculates the autocorrelation from the power spectrum using FFT. 

𝐶𝐶(𝜏𝜏) = � 𝑃𝑃�(𝑓𝑓)𝑒𝑒𝑖𝑖2𝜋𝜋𝜋𝜋𝜋𝜋𝑑𝑑𝑑𝑑
∞

−∞
 (33) 
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where 𝐶𝐶(𝜏𝜏) is the autocorrelation function, 𝑃𝑃�(𝑓𝑓) is the smoothed power spectrum and 𝜏𝜏 is the 
time lag. 

ViewWave plots graphs of the autocorrelation coefficient 𝑅𝑅(𝜏𝜏)  that is the normalized 
autocorrelation function by 𝐶𝐶(0). 

𝑅𝑅(𝜏𝜏) =
𝐶𝐶(𝜏𝜏)
𝐶𝐶(0)

 (34) 

5.7. Response spectrum 

The response spectra are defined as functions of the natural period 𝑇𝑇(= 2𝜋𝜋/𝜔𝜔0) and the damping 
ratio h of a SDOF system (see Fig. 62) as shown in Eq.(35) to Eq.(37), taking the maximum values 
of the responses. A plots of the natural period versus 𝑆𝑆d(𝑇𝑇,ℎ), 𝑆𝑆v(𝑇𝑇,ℎ) and 𝑆𝑆a(𝑇𝑇, ℎ) for a certain 
damping ratio are called the displacement, velocity and acceleration response spectra, respectively. 

𝑆𝑆d(𝑇𝑇,ℎ) = |𝑥𝑥(𝑡𝑡)|𝑚𝑚𝑚𝑚𝑚𝑚 (35) 

𝑆𝑆v(𝑇𝑇,ℎ) = |𝑥̇𝑥(𝑡𝑡)|𝑚𝑚𝑚𝑚𝑚𝑚 (36) 

𝑆𝑆a(𝑇𝑇,ℎ) = �𝑥̈𝑥(𝑡𝑡) + 𝑥̈𝑥𝑔𝑔(𝑡𝑡)�
𝑚𝑚𝑚𝑚𝑚𝑚 (37) 

Among the acceleration, velocity and displacement response spectra, there are relations as shown 
in Eq.(38) to Eq.(40). A tripartite plot makes it possible to indicate three response spectra in a graph, 
utilizing those relations. In a tripartite plot of ViewWave, the pseudo velocity spectrum 𝑆𝑆p v 
calculated from 𝑆𝑆a using Eq. (40) is adopted. 

𝑆𝑆d(𝑇𝑇,ℎ) ≈
𝑇𝑇

2𝜋𝜋
𝑆𝑆v(𝑇𝑇,ℎ) (38) 

 𝑆𝑆a(𝑇𝑇,ℎ) ≈
2𝜋𝜋
𝑇𝑇
𝑆𝑆v(𝑇𝑇,ℎ) (39) 

𝑆𝑆p v (𝑇𝑇, ℎ) =
𝑇𝑇

2𝜋𝜋
𝑆𝑆a(𝑇𝑇,ℎ) (40) 

5.8. Energy spectrum 

In terms of energy, the seismic response of the SDOF can be expressed as follows8); 

� 𝑚𝑚𝑥̈𝑥(𝑡𝑡)𝑥̇𝑥(𝑡𝑡)𝑑𝑑𝑑𝑑
𝑇𝑇𝑑𝑑

0
+ � 𝑐𝑐𝑥̇𝑥2(𝑡𝑡)𝑑𝑑𝑑𝑑

𝑇𝑇𝑑𝑑

0
+ � 𝑘𝑘𝑘𝑘(𝑡𝑡)𝑥̇𝑥(𝑡𝑡)𝑑𝑑𝑑𝑑

𝑇𝑇𝑑𝑑

0
= −� 𝑚𝑚𝑥̈𝑥𝑔𝑔(𝑡𝑡)𝑥̇𝑥(𝑡𝑡)𝑑𝑑𝑑𝑑

𝑇𝑇𝑑𝑑

0
 (41) 

where 𝑚𝑚, 𝑐𝑐 and 𝑘𝑘 are a mass, a damping coefficient and a spring constant of the system, 𝑇𝑇𝑑𝑑 is 
the duration time, 𝑥̈𝑥(𝑡𝑡) , 𝑥̇𝑥(𝑡𝑡)  and 𝑥𝑥(𝑡𝑡)  are acceleration, velocity and displacement of the 
response, and 𝑥̈𝑥𝑔𝑔(𝑡𝑡) is an input earthquake motion. The left hand side of the equation is the energy 
consumed by the system and the right hand side is the total energy exerted on the system by the 
earthquake motion. Therefore, the total energy input 𝐸𝐸 is defined as follow; 

𝐸𝐸 = −� 𝑚𝑚𝑥̈𝑥𝑔𝑔(𝑡𝑡)𝑥̇𝑥(𝑡𝑡)𝑑𝑑𝑑𝑑
𝑇𝑇𝑑𝑑

0
 (42) 
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The total energy input can be expressed by an equivalent velocity 𝑉𝑉E as follows; 

𝑉𝑉E = �2𝐸𝐸
𝑚𝑚

= �−2� 𝑥̈𝑥𝑔𝑔(𝑡𝑡)𝑥̇𝑥(𝑡𝑡)𝑑𝑑𝑑𝑑
𝑇𝑇𝑑𝑑

0
 (43) 

𝑉𝑉E is a function of the parameters of the SDOF system. So the energy spectrum is defined as the 
function of the natural period 𝑇𝑇 and the damping ratio ℎ. 

5.9. Relation analysis 

We often need to discuss relation between two channels of the strong motion data. There several 
ways to investigate the relation between two sets of time history data. 

5.9.1. Cross spectrum and Fourier spectrum ratio 

The cross spectrum of two time histories of acceleration data 𝑥𝑥(𝑡𝑡) and 𝑦𝑦(𝑡𝑡) is defined from those 
Fourier transforms 𝐹𝐹X(𝑓𝑓) and 𝐹𝐹Y(𝑓𝑓) as follows; 

𝑃𝑃XY(𝑓𝑓) = lim
𝑇𝑇→∞

1
𝑇𝑇
𝐹𝐹X∗(𝑓𝑓)𝐹𝐹Y(𝑓𝑓) (44) 

Following the similar procedure to the power spectrum, a cross spectrum is estimated by applying 
the spectrum window. 

𝑃𝑃XY(𝑓𝑓) =
1
𝑇𝑇
𝐹𝐹X∗(𝑓𝑓)𝐹𝐹Y(𝑓𝑓) (45) 

𝑅𝑅𝑅𝑅�𝑃𝑃�XY(𝑓𝑓)� = � 𝑅𝑅𝑅𝑅[𝑃𝑃XY(𝑓𝑓 − 𝜙𝜙)]𝑊𝑊(𝜙𝜙)𝑑𝑑𝑑𝑑
∞

−∞
 

𝐼𝐼𝐼𝐼�𝑃𝑃�XY(𝑓𝑓)� = � 𝐼𝐼𝐼𝐼[𝑃𝑃XY(𝑓𝑓 − 𝜙𝜙)]𝑊𝑊(𝜙𝜙)𝑑𝑑𝑑𝑑
∞

−∞
 

(46) 

where 𝑃𝑃XY(𝑓𝑓) is the raw cross spectrum, 𝐹𝐹X(𝑓𝑓) and 𝐹𝐹Y(𝑓𝑓) are the Fourier transforms of 𝑥𝑥(𝑡𝑡) 
and 𝑦𝑦(𝑡𝑡). 𝑃𝑃�XY(𝑓𝑓) is the smoothed cross spectrum, 𝑊𝑊(𝑓𝑓) is the spectrum window. 

The process for calculating the cross spectrum and Fourier spectrum ratio is as follow; 

1) Calculate the raw cross spectrum 𝑃𝑃XY(𝑓𝑓) from 𝐹𝐹X(𝑓𝑓) and 𝐹𝐹Y(𝑓𝑓) (Eq. (45)). 
2) Smooths the real and imaginary parts of 𝑃𝑃XY(𝑓𝑓) with the Parzen window (Eq. (46)). 
3) Calculate the amplitude �𝐻𝐻�XY(𝑓𝑓)� and phase 𝜃𝜃�XY(𝑓𝑓) of the Fourier spectrum ratio from the 

smoothed cross spectrum 𝑃𝑃�XY(𝑓𝑓) (Eqs. (47) and (48)). 

�𝐻𝐻�XY(𝑓𝑓)� = �
𝑃𝑃�YY(𝑓𝑓)
𝑃𝑃�XX(𝑓𝑓)

 (47) 

𝜃𝜃�XY(𝑓𝑓) = 𝑎𝑎𝑎𝑎𝑎𝑎�𝐻𝐻�XY(𝑓𝑓)� = tan−1 �−
𝐼𝐼𝐼𝐼�𝑃𝑃�XY(𝑓𝑓)�
𝑅𝑅𝑅𝑅�𝑃𝑃�XY(𝑓𝑓)�

� ,  −π < 𝜃𝜃XY(𝑓𝑓) ≤ π (48) 

The Fourier spectral ratio is complex number, so there are two expression ways, the amplitude and 
phase, and the real part and imaginary part. The cross spectrum is also complex number and its 
phase is the same as that of the Fourier spectral ratio. 
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5.9.2. Coherence 
The coherence is calculated from the power spectra and cross spectrum of two time histories of 
acceleration data. The definition is as follows; 

𝐶𝐶𝐶𝐶ℎXY(𝑓𝑓) =
�𝑃𝑃�XY(𝑓𝑓)�

�𝑃𝑃�X(𝑓𝑓)𝑃𝑃�Y(𝑓𝑓)
 (49) 

where 𝐶𝐶𝐶𝐶ℎXY(𝑓𝑓) is the coherence function, 𝑃𝑃�X(𝑓𝑓) and 𝑃𝑃�Y(𝑓𝑓) are the smoothed power spectra of 
𝑥𝑥(𝑡𝑡) and 𝑦𝑦(𝑡𝑡). 

5.9.3. Cross correlation coefficient 
The cross correlation coefficient is the normalized cross correlation function and is calculated by 
the similar way to the autocorrelation coefficient. ViewWave calculates the cross correlation 
function by the inverse Fourier transform of the cross spectrum using FFT. 

𝐶𝐶XY(𝜏𝜏) = � 𝑃𝑃�XY(𝑓𝑓)𝑒𝑒𝑖𝑖2𝜋𝜋𝜋𝜋𝜋𝜋𝑑𝑑𝑑𝑑
∞

−∞
 (50) 

𝑅𝑅XY(𝜏𝜏) =
𝐶𝐶XY(𝜏𝜏)
𝐶𝐶XY(0)

 (51) 

where 𝐶𝐶XY(𝜏𝜏) is the cross correlation function and 𝑅𝑅XY(𝜏𝜏) is the cross correlation coefficient. 

5.9.4. Response spectrum ratio 
The response spectrum ratio is simply calculated as the ratio between the response spectra of two 
acceleration data. ViewWave adopts the acceleration response spectrum to calculate the ratio; 

𝑅𝑅𝑆𝑆XY(𝑇𝑇,ℎ) =
𝑆𝑆𝑎𝑎Y(𝑇𝑇,ℎ)
𝑆𝑆𝑎𝑎X(𝑇𝑇,ℎ) (52) 

where 𝑅𝑅𝑆𝑆XY(𝑇𝑇,ℎ)  is the response spectrum ratio, 𝑆𝑆𝑎𝑎X(𝑇𝑇,ℎ) and 𝑆𝑆𝑎𝑎Y(𝑇𝑇,ℎ)  are the acceleration 
response spectra of 𝑥𝑥(𝑡𝑡) and 𝑦𝑦(𝑡𝑡). 

5.10. Preprocessing 

5.10.1. Band-pass filter 

If the band-pass filter is enabled, acceleration data is transformed using the FFT and filtered in the 
frequency domain. Then it is transformed into the time domain using the inverse FFT. The filter 
has real gain, so the phase is not affected. The band-pass filter is a product of a low-cut filter and a 
high-cut filter as shown in Eq. (53). The low-cut and high-cut filters are defined by Eq. (54) and Eq. 
(55), respectively, utilizing amplitudes of the Butterworth filter. 

𝐺𝐺B(𝑓𝑓) = 𝐺𝐺L(𝑓𝑓)𝐺𝐺H(𝑓𝑓) (53) 

𝐺𝐺L(𝑓𝑓) = �
(𝑓𝑓 𝑓𝑓L⁄ )2𝑛𝑛

1 + (𝑓𝑓 𝑓𝑓L⁄ )2𝑛𝑛
 (54) 

𝐺𝐺H(𝑓𝑓) = �
1

1 + (𝑓𝑓 𝑓𝑓H⁄ )2𝑛𝑛
 (55) 
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where 𝐺𝐺L(𝑓𝑓) and 𝐺𝐺H(𝑓𝑓) are gains of the low-cut and high-cut filters, 𝑓𝑓L and 𝑓𝑓H are the low-cut 
and high-cut frequencies. 

The filter shapes are determined by the cut-off frequencies 𝑓𝑓L, 𝑓𝑓H and the order n. If zero is given 
as the order, ViewWave uses the filters given by Eqs. (15) and (16) that are used in the calculation 
of the JMA seismic intensity. The filter shapes for n=5, n=10 and n=20 are shown in Fig. 65, together 
with that of the JMA filter. 

 
Fig. 65 Characteristics of low-cut (left) and high-cut (right) filters 

5.10.2. Rotation of acceleration data 

The installation azimuth of the strong motion instrument in buildings usually accords with the 
building axis. Therefore, we sometimes need to rotate strong motion data in the horizontal plane 
in order to discuss movements in North-South and East-West directions. ViewWave can rotate 
strong motion data after reading it assuming that the first and second channels are orthogonal 
horizontal directions. The rotation is made by the following coordinate transformation. 

𝑥𝑥𝑛𝑛𝑛𝑛𝑛𝑛(𝑡𝑡) = cos𝜃𝜃 𝑥𝑥𝑜𝑜𝑜𝑜𝑜𝑜(𝑡𝑡) − sin𝜃𝜃 𝑦𝑦𝑜𝑜𝑜𝑜𝑜𝑜(𝑡𝑡) 

𝑦𝑦𝑛𝑛𝑛𝑛𝑛𝑛(𝑡𝑡) = sin𝜃𝜃 𝑥𝑥𝑜𝑜𝑜𝑜𝑜𝑜(𝑡𝑡) + cos 𝜃𝜃 𝑦𝑦𝑜𝑜𝑜𝑜𝑜𝑜(𝑡𝑡) 
(56) 

where 𝑥𝑥𝑜𝑜𝑜𝑜𝑜𝑜(𝑡𝑡)  and 𝑦𝑦𝑜𝑜𝑜𝑜𝑜𝑜(𝑡𝑡)  are the original orthogonal horizontal components, 𝑥𝑥𝑛𝑛𝑛𝑛𝑛𝑛(𝑡𝑡)  and 
𝑦𝑦𝑛𝑛𝑛𝑛𝑛𝑛(𝑡𝑡) are the rotated horizontal components, and 𝜃𝜃 is the rotational angle. 

The rotation of the data in the N063°E and N153°E directions at 63° gives the data in the N000°E 
and N090°E directions, as shown in Fig. 66. 
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Fig. 66 Rotation of strong motion data in the horizontal plane 
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Power Plants. MIT Press, 1969: 438-483. 
8) Akiyama, Hiroshi: Earthquake-Resistant Limit-State Design for Buildings, University of Tokyo 

Press, 1985 

6.2. Programming 
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10) DOBON.NET プログラミング道: http://dobon.net/vb/ 
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12) Stack Overflow: http://stackoverflow.com/ 
13) Code Project: http://www.codeproject.com/ 
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